Customer Collections - Outbound Calling Disruption

Incident Report for Teleforce

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 16:43 EDT

Update

After a successful reboot of our AMD system, we are continuing to monitor for systems recovery.
Posted Aug 17, 2026 - 15:27 EDT

Update

We will be doing a partial reboot of the AMD system this afternoon. There will be temporary disruption before the calls resume as normal.
Posted Aug 17, 2026 - 14:17 EDT

Monitoring

We are monitoring this issue for continued improvement. We will continue to work with the service provider and provide updates as they come.
Posted Aug 17, 2026 - 11:53 EDT

Investigating

We are currently experiencing a service disruption affecting our Answering Machine Detection (AMD) provider used by our Customer Collections telephony platform. As a result, outbound collections calls are temporarily unavailable. Inbound calls continue to be received and routed normally.

We are working with the service provider to restore full functionality and will share additional updates as they become available.
Posted Aug 17, 2026 - 08:31 EDT
This incident affected: Third-Party Integrations (Software Services).