Intermittent Call Delivery Issues

Incident Report for Teleforce

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 19:26 EDT

Update

. Mitigation measures have been put in place to reduce the impact while we continue working toward a full resolution.
Posted Mar 19, 2026 - 16:54 EDT

Identified

We are currently experiencing intermittent Med Sales call delivery issues related to one of our service providers. This may result in occasional call failures or delays. We are actively working to identify mitigation measures and reduce the impact while we work toward a resolution.
Posted Mar 19, 2026 - 15:31 EDT
This incident affected: Third-Party Integrations (Telecom Providers, Software Services).